Beast Blog Theme for WordPress

Posted October 21st, 2005 by Mike Cherim

I have created a theme for WordPress web log users called “Beast Blog.” It’s what you’re seeing here and now. The style has recieved a lot of positive attention and I was asked by members of the WordPress community to make it available as an official WordPress theme release. I made this web log entry specifically to accept comments, complaints, bug reports, whatever Beast Blog related stuff you may have on your mind. If you wish to download this theme for your own use, or to get more information, please check out this permanent Official Beast Blog Theme Information Page.

To date, the “Beast Blog” theme has been downloaded 3332 times. I hope you’re enjoying it.


62 Responses to: “Beast Blog Theme for WordPress”

  1. Jonathan Fenocchi responds:
    Posted: October 21st, 2005 at 11:00 pm

    Kickin’ butt, man. It’s wicked awesome!

  2. Patrick responds:
    Posted: October 22nd, 2005 at 6:20 am

    Just great. you can see it here
    http://perso.argentine-news.com/
    Will send you french translation when finished

  3. Patrick responds:
    Posted: October 22nd, 2005 at 9:09 am

    Thanks Mike. I did the modif in CSS for ins element. In fact I am using ins element after the blockquote to be XHTML valid, only way I found.
    The translation will be ready next week, will sent you.
    Thanks again
    Patrick

  4. Patrick responds:
    Posted: October 22nd, 2005 at 5:38 pm

    Just a problem, the RSS for comments does´not work

  5. Patrick responds:
    Posted: October 23rd, 2005 at 6:36 am

    Well RSS comments are working, sorry, was a server problem.
    For the contact form, I am trying to fix the problem… he he not so easy for me
    Thanks for the banner, in fact I am better in design than in xhtml ;-)

  6. Patrick responds:
    Posted: October 24th, 2005 at 7:08 pm

    I sent you for mail french translation of your great theme

  7. penny responds:
    Posted: October 25th, 2005 at 1:56 am

    Hey nice blog and nice interface too.

  8. 8 Seconden » Beast Blog responds:
    Posted: October 25th, 2005 at 1:52 pm

    […] hemes by Michael on the October 25th, 2005

    Mike Cherim laat het Beast Blog theme op u los. Zachte kleuren, simpele opbouw en ontzettend stijlvol. […]

  9. sfong responds:
    Posted: November 1st, 2005 at 2:26 am

    Great theme! As you can see I have tried few other themes at my “wp playground” site. I would hope that you check few things out as below.

    The theme looks great in IE but I’m using Firefox and I found the fonts look a bit weird and too large (used smallest text size from tool>view already). The font is just right for IE6. The 2 search boxes also didn’t go inline in FF. FF has reached 10 millions download therefore we can’t ignore it.

    Also on the sidebar, if you view in FF, the texts don’t align when it’s wrapped.

    At links, does your theme support hierarchical arrangement, i.e. children categories are indent behind parent category?

    I haven’t looked inside yet but noticed that there is a Jscript file, what does it do really?

  10. sfong15 responds:
    Posted: November 1st, 2005 at 3:32 am

    Mike, I just posted 30 minutes ago. Spent that time tweaked the font size etc… it’s now looks close to what I want it too look, you could have a look at the url I sent with this comment. As the search button doesn’t align horizontally with the searchbox so I moved it to the next line but it still doesn’t look good.

    The children categories also indent a bit from its parent, that’s the way I like it. May be I put a dot in front of them later on.

    The banner image is a photo I took, hope you like the color match. I’ll find a way to put the clickable sitename on the image, this would do away the “home” button on the sidebar.

  11. sfong responds:
    Posted: November 1st, 2005 at 11:43 am

    Dear Mike,

    Thanks a lot really. As you can see I have tried a dozen themes, this is the first time I get coaching/sharing from the designer like this. Really impressed! I will experiment the tweaks you suggested in due course. Great work, keep it up.

  12. sfong responds:
    Posted: November 1st, 2005 at 12:38 pm

    Mike,

    Just tried adding a dot to the categories listing. There are 2 lines with “list-style-type : none;” within the sidebar section of the CSS file, tried both, I either get a dot in front of “pages”, “categories” heading or nothing. In essense I want to add a dot to the category listings with a dot. Any hint?

  13. sfong responds:
    Posted: November 2nd, 2005 at 12:18 pm

    Mike, thanks again. It’s almost there, see it again at my site.

  14. sfong responds:
    Posted: November 2nd, 2005 at 11:07 pm

    Mike,

    I have done CSS validation, result posted at my site. I have also turned on “anyone can comment” so you could comment there if you like. This will also test out if the
    Akismet plugin is working or not. You know by now my HTML/CSS skill is at dummies level. I have documented my experience and hope that it’ll be useful to you. I’ll let you know here when I have made further changes to your great theme.

  15. sfong responds:
    Posted: November 3rd, 2005 at 11:20 am

    Mike,

    I started over again, this time with IE running concurrently such that I can refresh it after each change made to the CSS file. It’s kind of fun and I’ll having a double. Do you want my “bad” CSS file?

  16. sfong responds:
    Posted: November 3rd, 2005 at 11:41 am

    Mike, I started from bare min change then arrived here as you can see with IE. The green dot is hitting the links heading. I believe I added the padding-left trying to move the heading to the right to avoid the green dot. 7px is the largest I could get, anything further will push it overboard, i.e. sidebar shifted down.

    #sidebar ul li h2 {
    /* below added */
    background : transparent url(images/bb_dot.gif) no-repeat 0 0;
    margin: 5px 0 0; /* was 5px */
    padding-left: 7px; /* was padding: 0 */
    font-size : 100%; /* was 100% */
    }

  17. sfong responds:
    Posted: November 3rd, 2005 at 12:37 pm

    Mike,

    Thanks for the encouragement, I think I’ll give up for now. Something also weird is that optioncount=1 is turned on but it doesn’t show?

    I think with the image included inside that CSS codes the trouble is that when I adjust the margin and/or padding I noticed that (bare eyes without ruler on the screen) the dot moves relative to the heading. I would have expected that the dot stays independent of my positioning of the heading.

    There must be a workaround somehow.

  18. sfong15 responds:
    Posted: November 3rd, 2005 at 11:35 pm

    Dear Mike,

    Not giving up completely yet. Latest attempt see this http://sfong.net/fun/2005/11/04/tried-this/

    Have also tried add img src=??? etc. I didn’t actually get the image but just the shade of it being placed above the heading, I believe using the dot class is the proper way similar to the way used for title of each post.

  19. sfong responds:
    Posted: November 4th, 2005 at 3:16 am

    Dear Mike,

    Re your advice of using Opera I have in fact done that when ver 8.5 was launched, I still have that installed. See posts about it and other browsers I tried here http://me.sfong.net/category/browsers/

    A bit off-topic but it’s true that theme designer like you has to be aware of behaviour of different browsers.

  20. sfong responds:
    Posted: November 9th, 2005 at 5:46 am

    Mike, one other thing, when I click one category under sidebar it gives me a list of posts but images are not displayed within the post until I click that post title to expand it. Is there any way to make displaying of images within posts by default? I think behaviour is the same for month archives.

  21. sfong responds:
    Posted: November 11th, 2005 at 12:14 pm

    Mike,

    The answer is here http://wordpress.org/support/topic/40924

  22. sirocco responds:
    Posted: November 11th, 2005 at 11:40 pm

    Hi.
    I like your theme. Looks very simple and clean. :-)
    But I have a problem: I can’t see the banner image and just see the text title in Opera 8.5/Win 2000.
    How can I fix it?

  23. sirocco responds:
    Posted: November 12th, 2005 at 3:55 am

    Thank you for advice, Mike.
    After re-installed Opera, I found it fixed. But actually don’t figure out what happened.
    Maybe the permission problem? During Opera have a trouble, It worked well in IE.

  24. sirocco responds:
    Posted: November 12th, 2005 at 10:12 am

    Well, can it be better that changing ‘bb_banner.jpg’ to ‘bb_banner.png’ ?

  25. WebtrafficJunkie responds:
    Posted: November 17th, 2005 at 9:44 pm

    I love your theme. It is so clean and simple. I am seriously considering it for my new page when I finish!

  26. How To Blog responds:
    Posted: November 30th, 2005 at 10:28 pm

    Comprehensive list of 463 Free WordPress 1.5 Themes / Templates available for download

    Largest list of free WordPress Themes. Over 460 wordpress 1.5 themes, including numerous 3-column wp template layouts, updated regularly

  27. Darlene responds:
    Posted: December 11th, 2005 at 7:45 pm

    Hi there! Love the theme! One issue that I have not seen addressed here (so perhaps I am alone in having this issue) is that in IE, the sidebar is not starting until the main content is completed.
    It works ok in Firefox but not IE. Any suggestions? The site can be seen at http://www.romyandjacob.com/blog - thanks!

  28. Darlene responds:
    Posted: December 22nd, 2005 at 2:11 pm

    Hi Mike!
    Thanks for the info! Sorry I didn’t check back in here earlier - you’d save me so much time ;-) I didn’t realize the credit had been removed from the footer as I didn’t do the actual work (and therefore can’t take credit for that work), but am working on having it put back in ASAP! My apologies.

    I just scanned a more recent post - you’d like to find some design work? Do touch base with me - I outsource all the design work that I require…

    Oh - and being found by others (Re: chickletization) - did you know that a “blogroll” is not search engine friendly quite often? So if you have other people linking to your blog from theirs via a blogroll, you are not receiving proper search engine credit for that link.

    Darlene

  29. Matt Kincaid responds:
    Posted: January 26th, 2006 at 11:19 am

    Thanks for this great theme. I really appreciate the accessibility functions, and how nicely it all works. I hope to learn some more about accessible websites so that my posts are just as nicely formatted as your theme is.
    I had some problems with IE visitors seeing the navigation bar dropping below the rest of the content like someone else had mentioned in the comments, but resizing the narrow column didn’t help. I’m under the impression the problem is the expanding box bug with IE/CSS. The text that isn’t wrapping around is right above the search field. It only happened under bizarre circumstances on other websites when I had IE’s zoom at it’s highest setting. On my site though, because my site name is so long it happened on the default settings. I couldn’t figure out why the text wasn’t wrapping, I saw nothing suspicious in the CSS file. I changed the search.php to just be my first name and that fixed most pages. I also had this habit of throwing large photos in some posts that were larger then the narrow column field which would also cause the sidebar to wrap around. I added a overflow:hidden to narrow column to fix that and haven’t seen any problem since.

    Thanks again!

  30. hypotheken responds:
    Posted: February 6th, 2006 at 5:57 am

    Hi, I think you are totally right. Great! - :) Susan.

  31. adobual responds:
    Posted: February 6th, 2006 at 1:57 pm

    I was searching the web and found your entry. I really like your site and found it worth while reading through the posts. I am looking to publish a comprehensive site reviewing many different articles and blog.

  32. Jessica responds:
    Posted: February 20th, 2006 at 7:05 pm

    Fabulous theme. I’ve tweaked it and am using it on http://www.cranky-mama.com. Thanks!

  33. TreeFrog responds:
    Posted: February 21st, 2006 at 11:37 pm

    Terrific Blog you have. Peace Out.
    TreeFrog

  34. Cathryn responds:
    Posted: March 3rd, 2006 at 1:38 am

    nice nice!

  35. Monroe responds:
    Posted: March 3rd, 2006 at 6:12 pm

    Wow. Glad I came across this blog.

  36. JiggyWittit responds:
    Posted: March 6th, 2006 at 5:52 am

    Kewl blog you got goin on up here.
    Peace, JiggyWittit

  37. No Keyword Here responds:
    Posted: March 22nd, 2006 at 9:02 pm

    Personally, I never use more than a single link in the comment I post because doing so can trigger spam catchers if the user has that plugin activated, whereas a single link will not.

Sorry. Comments are closed.




Note: This is the end of the usable page. The image(s) below are preloaded for performance only.